TYPO3: Lösung für: Es können keine neuen Elemente angelegt werden

Unter TYPO3 4.7.2 können mit TemplaVoila unter Umständen keine neuen Elemente angelegt werden. Es erscheint die Fehlermeldung „Sie haben nicht die nötigen Rechte, um diese Änderung durchzuführen.“ Dies liegt an einer nicht mehr vorhandenen Spalte t3ver_swapmode in der pages-Tabelle in der Datenbank. Diese kann man einfach wieder hinzufügen. Sie muss vom Typ tinyint sein und standardmäßig den Wert 0 haben.

6 Gedanken zu „TYPO3: Lösung für: Es können keine neuen Elemente angelegt werden

  1. Markus Kundert

    Vielen Dank für die Lösung, ist übrigens auch TYPO3 4.7.3 genau gleich
    Hoffen wir, dass dies bald gefixt wird

  2. fleischer

    Import der t3d-Dateien funktioniert nicht in Typo3 Version 4.7.11. Es wird nur ein weißes Fenster angezeigt und keine Datensätze angelegt.
    Was kann ich da tun?

    Andreas

  3. Sven Wappler Beitragsautor

    Das deutet immer darauf hin, dass entweder der Timeout für PHP zu niedrig ist oder PHP zu wenig Arbeitsspeicher zur Verfügung steht. Am besten mal die Ausgabe von Fehlermeldungen anschalten.

  4. Fleischer

    Hallo Sven,
    danke für die Information. Der Import verlief soweit gut. Die Domäne ist angepasst. Es kommt die Fehlermeldung : TemplaVoila ERROR:

    Couldn’t find Template Object with UID „1005“.
    Please make sure a Template Object is accessible.

    Wir möchten für ein Afrikanisches Hilfswerk dieses Template nutzen.

    Ich habe in TemplaVoila den Assistenten gestartet zum Auffrischen und ich soll die HTML-Vorlagedatei wählen. Nur die Frage für mich – welche ist das?

    Danke vom voraus Andreas

  5. fleischer

    Hallo Sven,
    habe das Layout zugeordnet – und es funktioniert :-} – super.
    Ich möchte auch die Hilfsnavigation sichtbar machen. Wo und wie kann ich dies hinterlegen?

    Danke

    Andreas

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.